九度OJ-1001

-好久没有刷过OJ
-三次才AC

题目描述:
This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.
输入:
The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.
The input is terminated by a zero M and that case must NOT be processed.
输出:
For each test case you should output in one line the total number of zero rows and columns of A+B.
样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:
2011年浙江大学计算机及软件工程研究生机试真题


题目的意思大概是输入两个数作为数组的行数和列数,然后读入两个这样的数组,执行加法操作,算出元素均为0的行数列数的和。


AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include<iostream>
using namespace std;
int main(){
int m,n; //读入数组的行列数
int i,j;
int count1,count2=0; //计数器
while(cin>>m>>n&&m){
int a[m][n];
int b[m][n];
count2=0; //归零操作
for(i=0;i<m;i++) //读入第一个数组
for(j=0;j<n;j++)
cin>>a[i][j];
for(i=0;i<m;i++) //读入第二个数组
for(j=0;j<n;j++){
cin>>b[i][j];
a[i][j]+=b[i][j]; //执行数组的加法
}
for(i=0;i<m;i++){ //算出有多少行是元素均为0的
for(j=0;j<n;j++)
if(a[i][j]==0)
count1++;
if(count1==n)
count2++;
count1=0; //归零操作
}
for(j=0;j<n;j++){ //算出有多少列是元素均为0的
for(i=0;i<m;i++)
if(a[i][j]==0)
count1++;
if(count1==m)
count2++;
count1=0; //归零操作
}
cout<<count2<<endl;
}
return 0;
}
Thanks for your reward!