HDOJ-1001

-simple
-sum problem


Sum Problem

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 500758 Accepted Submission(s): 127099

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050


sum问题,注意下中间多一个空行就好


AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
#include<iostream>
using namespace std;
int main(){
int x;
int i,sum=0;
while(cin>>x){
for(i=0;i<=x;i++)
sum+=i;
cout<<sum<<endl<<endl;
sum=0;
}
return 0;
}


Thanks for your reward!