PAT-A1046题解

-简单模拟


PAT-A1046. Shortest Distance (20)
【时间限制】
100 ms
【内存限制】
65536 kB
【代码长度限制】
16000 B
【Abstract】
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
【Input Specification】
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
【Output Specification】
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
【Sample Input】
5 1 2 4 14 9
3
1 3
2 5
4 1
【Sample Output】
3
10
7


题目的意思大致是:
给你n个结点两两之间的距离。
然后进行m次查询,每次查询给你2个结点。求最短距离。


错误代码示范:
错误的原因主要在于太过暴力。完全没有考虑到时间复杂度。在这么大的时间复杂度下是不可能在Limit 100ms下跑完的。因此此代码还需要进行一些处理。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include<iostream>
using namespace std;
const int MAXN=100010;
int main(){
int n;
int m; //查询次数
int a,b; //查询的结点
int D1=0;
int D2=0; //不同方向计算的距离
int Distance[MAXN];
int temp;
cin>>n;
for(int i=0;i<n;i++){ //读入结点之间距离
cin>>Distance[i];
}
cin>>m;
for(int i=0;i<m;i++){
D1=0; //清零操作
D2=0;
cin>>a>>b;
if(a>b){
temp=a;
a=b;
b=temp;
}
for(int j=a-1;j<=b-2;j++){
D1+=Distance[j];
}
for(int j=b-1;j<n;j++){
D2+=Distance[j];
}
for(int j=0;j<a-1;j++){
D2+=Distance[j];
}
if(D1>D2)
cout<<D2;
else
cout<<D1;
if(i!=m-1)
cout<<endl;
}
return 0;
}


AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=100005;
int dis[MAXN],A[MAXN]; //dis数组表示1结点顺时针到达i结点的距离
int main(){
int sum=0,m,n,left,right;
cin>>n;
for(int i=1;i<=n;i++){
cin>>A[i];
sum+=A[i]; //累加数组
dis[i]=sum; //预处理dis数组
}
cin>>m;
for(int i=0;i<m;i++){
cin>>left>>right;
if(left>right)
swap(left,right);
int temp=dis[right-1]-dis[left-1];
cout<<min(temp,sum-temp)<<endl;
}
return 0;
}


Thanks for your reward!